summaryrefslogtreecommitdiff
path: root/tw/packages/alice.scm
diff options
context:
space:
mode:
authorTimo Wilken2023-03-04 19:16:38 +0100
committerTimo Wilken2023-03-04 19:16:38 +0100
commitec2e893a8d6f1389a4abf4230ba8aa1cbf4d14b8 (patch)
treebe0f14d4529b5c347e6dfeb88abde69cfc42bf90 /tw/packages/alice.scm
parent64eee1d05998ea5354a58a2c30c9904f46a07f47 (diff)
Install alidistlint and fix its setup
Newer versions of alidistlint are Python 3.9-compatible.
Diffstat (limited to 'tw/packages/alice.scm')
-rw-r--r--tw/packages/alice.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/tw/packages/alice.scm b/tw/packages/alice.scm
index 154e8ad7..9039d008 100644
--- a/tw/packages/alice.scm
+++ b/tw/packages/alice.scm
@@ -48,14 +48,15 @@
(define-public python-alidistlint
(package
(name "python-alidistlint")
- (version "1.3.0")
+ (version "1.3.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "alidistlint" version))
- (sha256 (base32 "1y8wvyy3yn0zw542iy8cajm5k6kilkmr7ix1hl7vvlbsc9d30wcq"))))
+ (sha256 (base32 "168x6qfh2k4ivzq611ddb32ksd0914d70lcnz8qzx202l49xbf9x"))))
(build-system pyproject-build-system) ; we don't have setup.py, only pyproject.toml
(arguments '(#:tests? #f)) ; there are no tests, and build fails if #t
(propagated-inputs (list python-cerberus python-pyyaml))
+ (native-inputs (list python-setuptools-scm))
(home-page "https://github.com/TimoWilken/alidistlint")
(synopsis "A code linter for alidist packages")
(description "This package provides a code linter for alidist packages.")